4.3. Account Register/General Journal

4.3.1. Account Register & General Journal Window

This window is used to enter and edit your account data. It also provides tools for scheduling future transactions, finding and reporting on transactions and printing checks.

To open the Account Register Window for an account, select the account in the Account Tree then go to FileOpen Account or press Ctrl+O . This will open a new window with the Account Register. Pressing the Open button on the Toolbar in the Account Tree Window or the Jump button in the Account Register Window are alternate methods.

Figure 4.3. The Account Register Display.

Account Register screen

This is an image of the Account Register tab.


Tip

Appearance of the Account Register Display is highly customizable (see Tutorial and Concepts Guide, Choosing a Register Style) and Setting Column Widths).

Note

The methods to enter transactions are described in detail in Chapter 6, Common Transaction Operations.

4.3.2. Account Register Menus

The Menubar for the Transaction Register window contains the following options.

4.3.2.1. Account Register - File Menu

Clicking on File in the Menubar will pull down a menu of choices described in Table 4.1, “Account Tree - File-Menu - Access to file, account operations and printing.”.

The following table describes the additional options in the File Menu.

Table 4.11. Account Register - File-Menu - Access to file and account operations and printing.

Menu Item

Description

Print Checks... (Ctrl+P)

Starts the Print Checks assistant. See Section 6.15, “Printing Checks”.

Close (Ctrl+W)

Closes the currently opened transaction register.


4.3.2.2. Account Register - Edit Menu

The Menubar in the Edit menu includes, in addition to the items described in Table 4.2, “Account Tree - Edit-Menu - Access to file and account editing operations and preferences.” the following menu items.

Table 4.12. Account Register - Edit Menu - Access to file and account editing operations and preferences.

Menu Item

Description

Assign as payment...

Assign as payment the selected transaction.


4.3.2.3. Account Register - View Menu

The View menu in the Menubar. Table 4.3, “Account Tree - View-Menu - Changes display window view.” is supplemented for the transaction view by the following entries.

Table 4.13. Account Register - View-Menu - Changes GnuCash display window characteristics.

Menu Item

Description

Basic Ledger

Radio button to select register display mode. See Tutorial and Concepts Guide, Choosing a Register Style.

Auto-Split Ledger

Radio button to select register display mode.

Transaction Journal

Radio button to select register display mode.

Double Line

Check-box to enable/disable display of Double Line display.

Sort by...

Set the sort order of the transactions display. Requires a click to start options form. Option form requires Cancel/OK to close.

 

Standard Order

Keep normal order: date posted [day], number, date entered [second] [a] , description.

 

Date

Sort by date.

 

Date of Entry

Sort by date of entry.

 

Statement Date

Sort by the statement date (unreconciled items last).

 

Number

Sort by number.

 

Amount

Sort by amount.

 

Memo

Sort by memo.

 

Description

Sort by Description.

 

Action

Sort by action field.

 

Notes

Sort by notes field.

 

Reverse Order

Reverse the sort order.

 

Save Sort Order

Save the sort order between sessions.

[a] The date entered is usually invisible. Use a report to display it.


4.3.2.4. Account Register - Transaction Menu

Table 4.14. Account Register - Transaction-Menu - access to transaction tools.

Menu Item

Description

Cut Transaction

Cut the selected transaction into the clipboard.

Copy Transaction

Copy the selected transaction into the clipboard.

Paste Transaction

Paste the selected transaction from the clipboard.

Duplicate Transaction

Insert in the register a copy of the selected transaction.

Delete Transaction

Delete the selected transaction.

Remove Other Splits

Remove all splits from the selected transaction.

Enter Transaction

Enter in the register the transaction you are currently working on.

Cancel Transaction

Blanks all fields in the selected transaction if it has not yet been recorded.

Void Transaction

Void the selected transaction.

Unvoid Transaction

Unvoid the selected transaction.

Note

This menu item is only displayed if the selected transaction is marked as void.

Add Reversing Transaction

Add a copy of the selected transaction with an inverted amount.

Manage Document Link...

Add, change or unlink the document linked with the selected transaction.

Open Linked Document

Open the linked document for the current transaction.

Note

Only available if a file or location was associated with the currently selected transaction.

Jump to Invoice

Opens the invoice for the current transaction.

Note

Only available if a invoice was associated with the currently selected transaction.


4.3.2.5. Account Register - Actions Menu

The basic scope of the Actions menu in the Menubar is described in Table 4.4, “Account Tree - Actions-Menu - Setup scheduled transactions, repair accounts, perform stock splits, transfer and reconcile transactions.”. In addition, the following menu items are available.

Table 4.15. Account Register - Actions-Menu - Setup scheduled transactions, repair accounts, perform stock splits, transfer and reconcile transactions.

Menu Item

Description

Blank Transaction (Ctrl+Page Down)

Move to the blank transaction at the bottom of the register

Go to Date (Ctrl+G)

Move to the split at the specified date.

Split Transaction

Expand the currently selected transaction to show splits.

Edit Exchange Rate

Edit the exchange rate for the current transaction.

Schedule...

Create a Scheduled Transaction with the current transaction as a template.

Jump to the other account

Jump to the corresponding transaction in the other account.


4.3.2.6. Account Register - Busines Menu

The items shown in the Business menu are the same as listed in Table 4.5, “Account Tree - Business-Menu - Access small business features of GnuCash.”.

4.3.2.7. Account Register - Reports Menu

The items shown in the Reports menu are the same as listed in Table 4.6, “Account Tree - Reports-Menu - Access GnuCash Reports and Charts.” plus the two types of report listed in the following.

Table 4.16. Account Register - Reports-Menu - Access GnuCash Reports and Charts.

Menu Item

Description

Account report

Open a register report for this Account.

Account Transaction Report

Open a register report for the selected Account.


4.3.2.8. Account Register - Tools Menu

The items shown in the Tools menu are the same as listed in Table 4.7, “Account Tree - Tools-Menu - Access to miscellaneous tools and editors”.

4.3.2.9. Account Register - Windows Menu

The items shown in the Windows menu are the same as listed in Table 4.8, “Account Tree - Windows-Menu”.

4.3.2.10. Account Register - Help Menu

The items shown in the Help menu are the same as listed in Table 4.9, “Account Tree - Help-Menu - Access to this help and the Tutorial and Concepts Guide.”.

4.3.3. Account Register - Toolbar Icons/Buttons

The GnuCash main Window has a number of icons/buttons in the Toolbar to quickly access some common functions used with the specific active tab. The Toolbar can be hidden or shown by selecting the Toolbar item on the View menu.

Note

The specific options displayed in the Toolbar varies by the functions available to the active tab.

Tip

A brief description of the function of a button is displayed when the mouse pointer is placed over the button for a couple of seconds.

Table 4.17. Account Register (Transaction Register) Window Toolbar

Toolbar Buttons

Description

Save

Perform a save on the data file, commit all transactions to the data file.

Note

This item is only active if changed data has not yet been saved.

Close

Close this register.

Note

In the initial Account tree this item is not available - it will be grayed out.

Duplicate

Make a copy of the current transaction.

Delete

Delete the current transaction in this register.

Enter

Record the current transaction.

Cancel

Cancel the current transaction.

Blank

Move to a blank transaction at bottom of register.

Split

Show all splits in the current transaction. Not highlighted if ViewAuto-Split Ledger is enabled.

Jump

Jump to the corresponding transaction in the other account

Schedule

Create a Scheduled Transaction with the current transaction as a template.

Transfer

Start the transfer assistant to transfer funds from one account to another.

Reconcile

Start the Reconcile process for the selected account. Section 5.8, “Reconciling an Account to a Statement”


4.3.4. Tab Bar

The Tab bar displays notebook/file folder style tabs for open transaction registers, account trees and reports.

4.3.5. List of Transactions

The List of Transactions displays transactions you have entered and a running balance. It also provides a blank transaction to enter new transactions. The column headings vary according to what type of account you have opened. Common headings are Date, Description, Transfer and Balance.

The View menu can be used to alter the appearance of the List of Transactions. Possible changes are limiting the number of transactions shown, using a different sort order and changing the style to more easily see transactions. The Split button also provides quick access to view all the parts of a transaction.

4.3.6. Summarybar

The Summarybar displays balances appropriate for the opened account type at a glance. Usually accounts display Present (today’s) account balance, any balance for Future dates, a balance for Cleared items, a Reconciled balance and a Projected Minimum balance. Stock accounts, however, display shares totals and their value. The Summarybar can be hidden or shown by selecting the ViewSummarybar item.

4.3.7. Statusbar

The Statusbar works the same as described in Section 4.2.6, “Statusbar”.